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Bug - Problem #6511 - Samples | Submissions | Date details are not saving correctly on sample form - RESOLVED

Symptoms:

A user that enters a date into the "Sample collection date" or "Last treatment date" fields may have the dates roll back or forward one day when submitting or closing and then re-opening the sample form.

Root Cause:

Dates stored in the Micro-I database are stored in UTC (Coordinated Universal Time) but are then incorrectly loaded when the sample form is saved/loaded, causing the date to change.

Status: Resolved 

03/10/2023: Hotfix v3.6.4.0 released.

29/09/2023: Our development team currently has a solution undergoing testing.

27/09/2023: This issue has been brought to our attention. 

ETA Tuesday 3rd October

We thank you for your patience and understanding. Please don't hesitate to contact our Customer Support team if you require assistance, we are always happy to help. 

User actions required:

  • Ensure your Micro-I is running the latest version v3.6.4.0.
  • If you notice that any submissions have the incorrect dates applied, please get in contact with us at help@fecpakg2.com, including the submission ID or sample ID, and the correct dates for the fields that have the incorrect dates applied. We will be able to apply the correct dates and get the updated results sent out to you.